Q. What are the requirements to run eazyCMS?

Since eazyCMS is an online CMS, all you need is a copy of a recent up-to-date browser like Microsoft Internet Explorer, or Mozilla FireFox and a web connection.

To run the eazyCMS Mobile App you need an Android Smartphone, a BlackBerry Playbook, an Apple iPhone or an Apple iPad.

Back to FAQ Page

CHAT WITH US ONLINE...

 We are currently ONLINE
Chat is usually manned 8:30am-5pm
Build a site Sign up for our newsletter
© 2013 Eazyweb Internet Services Ltd